1. #1
    Avatar von DMW007
    Registriert seit
    15.11.2011
    Beiträge
    4.691
    Thanked 8.826 Times in 2.767 Posts
    Blog Entries
    5

    Standard

    Dieser Beitrag zeigt, wie man das WLAN auf dem Raspberry Pi einrichten oder ändern kann - sowohl per Konsole (z.B. SSH oder über angeschlossene Geräte) als auch über die grafische Oberfläche.




    Textversion im Portal: Raspberry Pi WLAN Verbindung nachträglich einrichten oder ändern- so geht es (grafisch + Konsole)

  2. #2
    Avatar von U-Labs YouTube
    Registriert seit
    30.09.2021
    Beiträge
    19
    Thanked 4 Times in 4 Posts

    Standard AW: Raspberry Pi WLAN einrichten oder WLAN ändern: Netzwerk & Internet per Funk auf dem Pi für Anfän

    Danke für das Video, jedoch bekomme ich direkt
    Code:
    wlan0     Interface doesn't support scanning : Network is down
    nachdem ich
    Code:
    sudo iwlist wlan0 scan
    abschicke.

    Das Netzwerk ist aber nicht down.

    Kommentar von Anton K.

  3. #3
    Avatar von DMW007
    Registriert seit
    15.11.2011
    Beiträge
    4.691
    Thanked 8.826 Times in 2.767 Posts
    Blog Entries
    5

    Standard

    Hi,

    möglicherweise ist die Schnittstelle blockiert, mit rfkill kannst du das herausfinden. Die Schnittstelle heißt dort nicht wlan0 sondern phyX, aber rechts daneben steht Wireless LAN:
    Code:
    $ sudo rfkill list all
    0: phy0: Wireless LAN
            Soft blocked: yes
            Hard blocked: no
    In diesem Falle kannst du wie folgt entsperren, die Blockierung sollte danach verschwunden sein:
    Code:
    $ sudo rfkill unblock wifi
    $ sudo rfkill list all
    0: phy0: Wireless LAN
            Soft blocked: yes
            Hard blocked: no
    Danach funktioniert der Scan wieder:
    Code:
    $ sudo iwlist wlan0 scan
    wlan0    Scan completed :
              Cell 01 - Address: ....
    Falls dieses Problem bei dir nicht aufgetreten ist, dann bitte einmal versuchen die Schnittstelle zu aktivieren und eventuelle Fehler posten, sofern welche erscheinen:
    Code:
    sudo ifconfig wlan0 up
    Sollte obige Variante funktionieren, unbedingt prüfen, ob die WLAN-Region gesetzt ist:
    Code:
    $ sudo grep country /etc/wpa_supplicant/wpa_supplicant.conf 
    country=DE
    Standardmäßig ist diese nicht gesetzt und wenn sie fehlt, wird das WLAN-Modul blockiert. Das korrekte Land zu setzen ist aufgrund der international nicht genormten Frequenzen notwendig.

  4. #4
    Avatar von U-Labs YouTube
    Registriert seit
    30.09.2021
    Beiträge
    19
    Thanked 4 Times in 4 Posts

    Standard AW: Raspberry Pi WLAN einrichten oder WLAN ändern: Netzwerk & Internet per Funk auf dem Pi für Anfän

    Wo wie schnell! Ich danke Dir!
    Noch eine Frage. Ich richte die Cloud für einen Freund ein. Er gab mir seine SSID etc. Die SSID beinhaltet aber ein Ausrufezeichen. Mit diesem scheint er ein Problem zu haben:

    Code:
    Meldung: -bash: !Box: event not found
    Ich habe jetzt auch ein Backslash hinzugefügt und es lief durch. Testen kann ich er am Wochenende, aber ist das der richtige Weg gewesen?

    Folgend siehts aus:
    ssid="FRITZ\!Box 7590 DB"

    Kommentar von Anton K..

  5. #5
    Avatar von DMW007
    Registriert seit
    15.11.2011
    Beiträge
    4.691
    Thanked 8.826 Times in 2.767 Posts
    Blog Entries
    5

    Standard

    Hi,
    dem Fehler nach vermute ich, du nutzt wpa_cli auf der Konsole und versuchst damit die SSID zu setzen, etwa so:
    Code:
    $ sudo wpa_cli set_network 0 ssid "FRITZ!Box 7590 DB"
    -bash: !Box: event not found
    TL;DR Einfachste Lösung
    Nutze
    Code:
    sudo raspi-config
    und navigiere zu 1 System Options > S1 Wireless LAN. Dort gibst du den Name (SSID) und den Netzwerkschlüssel (passphrase) ein, anschließend mit Finish beenden. Das erzeugt dir einen korrekten Eintrag in der wpa_supplicant.conf Konfiguration und maskiert ihn entsprechend, sodass dein Ausrufezeichen kein Problem darstellt. Beachte allerdings, das WLAN-Land unter 4 Localisation Options > L4 WLAN Country entsprechend deines Landes auf Deutschland, Schweiz, Österreich etc. zu setzen, falls noch nicht geschehen. Ansonsten kann es zu Problemen kommen, wie zum vorherigen Network is down Problem.

    Alternative: Manuell eintragen, aber ohne Maskierung
    Du kannst die Datei alternativ /etc/wpa_supplicant/wpa_supplicant.conf auch händisch bearbeiten, was v.a. zur Automatisierung sinnvoll ist. Allerdings solltest du hier keine Escape-Sequenzen verwenden! Der WPA-Client hat kein Problem mit dem Ausrufezeichen, dies entsteht durch die Bash-Shell (siehe unten). Die SSID sollte dort also lauten:
    Code:
    ssid="FRITZ!Box 7590 DB"
    statt
    Code:
    ssid="FRITZ\!Box 7590 DB"

    Erklärung zum "event not found" Fehler und Lösung auf der Kommandozeile mit wpa_cli
    In Zeichenketten mit doppelten Anführungszeichen wertet Bash sämtliche Variablen und Zeichen mit speziellen Bedeutungen aus. Das betrifft Variablen, "$name" z.B. bedeutet, dass $name mit dem Wert der Variable ersetzt wird. Das Ausrufezeichen hat eine spezielle Bedeutung, wenn History Expansion aktiviert ist: Dann legt es einen Suchbegriff fest, um den Befehlsverlauf zu durchsuchen:

    Code:
    pi@testpi:~ $ echo "Hi"
    Hi
    pi@testpi:~ $ !echo
    echo "Hi"
    Hi
    In deiner SSID sucht Bash daher nach einem Befehl mit "Box" und wirft einen Fehler, weil kein entsprechender Befehl im Verlauf gefunden wurde:
    Code:
    $ echo "!asdf"
    -bash: !asdf: event not found
    Das kann man einfach lösen, in dem die Zeichenkette in einfache Anführungszeichen maskiert wird:
    Code:
    $ echo 'asdf!'
    asdf!
    Für den wpa_cli Aufruf reicht das allerdings nicht, da deine SSID Leerzeichen enthält. In diesem Falle kann man einfache und doppelte Anführungsstriche kombinieren: Die einfachen zuerst, damit keine Interpretierung durch die Shell stattfindet. Die doppelten sind für wpa_supplicant, werden also 1:1 übergeben:
    Code:
    $ sudo wpa_cli set_network 0 ssid '"FRITZ!Box 7590 DB"'
    Selected interface 'p2p-dev-wlan0'
    OK
    Bedenke jedoch, dass das in der Form nur funktioniert, wenn bereits ein Netzwerk erstellt wurde. Ist das nicht der Fall, erzeugt obiger Aufruf kein neues Netzwerk-Element in der Konfiguration:
    Code:
    $ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=DE
    Ein neues Netzwerk legst du am einfachsten im interaktiven Modus an. Dort hast du das obige Problem zudem nicht, da dein Netzwerkname nicht erst über die Bash an wpa_cli weitergeleitet wird:
    Code:
    $ wpa_cli
    Selected interface 'p2p-dev-wlan0'
    Interactive mode
    
    > add_network
    2
    > set_network 2 ssid "FRITZ!Box 7590 DB"
    OK
    > enable_network 2
    OK
    > save_config
    OK
    > quit
    
    $ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    
    network={
            ssid="FRITZ!Box 7590 DB"
            psk="xxxxxxxx"
    }
    Hier allerdings auf das Land achten, wie man sieht wurde die "country" Zeile überschrieben und sollte wie im vorherigen Post gezeigt ergänzt werden:
    Code:
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=DE
    
    network={ 
    ...
    Generelle Empfehlung für WLAN-Netzwerke
    Ich würde grundsätzlich nie die Standard-Einstellungen hinsichtlich Netzwerkname (SSID) und vor allem WLAN-Schlüssel beibehalten. Primär aus Sicherheitsgründen: Die Generatoren für die Schlüssel z.B. sind oft nicht sauber, wodurch sich der WLAN-Schlüssel teils deutlich einfacher knacken oder einfach zurückbrechnen lässt. Standard-Netzwerknamen sind auch so eine Sache. Gerade Modellnamen á la Fritz!Box 7590 würde ich ebenfalls ändern und möglichst jegliche Leer- und Sonderzeichen vermeiden. Das verhindert zum einen Probleme wegen dieser Zeichen (wenngleich das heute eher selten ist) und das Verbinden mit dem falschen Netzwerk. Gerade in größeren Wohngebieten hat man nicht selten mehrere Geräte mit ähnlichem oder gleichem Name in der Nähe. Am besten keine Namen die irgendwelche persönlichen Daten beinhalten sondern was neutrales wie MyWLAN123 oder so was zusammen mit einem möglichst zufälligen, langen Passwort.

Diese Seite nutzt Cookies, um das Nutzererlebnis zu verbessern. Klicken Sie hier, um das Cookie-Tracking zu deaktivieren.