1. #1
    Avatar von DMW007
    Registriert seit
    15.11.2011
    Beiträge
    4.741
    Thanked 8.849 Times in 2.786 Posts
    Blog Entries
    5

    Standard Per Remotedesktopverbindung (RDP) auf den grafischen Desktop des Raspberry Pi zugreifen

    Mit XRDP gibt es eine freie Server-Implementierung für das unter Windows verbreitete Remotedesktop-Protokoll. Damit kann man sich von einem Windows PC/Laptop auf die grafische Oberfläche eines Raspberry Pi verbinden. Voraussetzung ist, dass eine grafische Desktopumgebung auf dem Raspberry Pi (nach-) installiert ist.



    Raspberry Pi: Windows Remote Desktop (Remotedesktopverbindung) einrichten (Textversion)

  2. The Following User Says Thank You to DMW007 For This Useful Post:

    Darkfield (22.11.2021)

  3. #2

    Registriert seit
    19.11.2021
    Beiträge
    3
    Thanked 1 Time in 1 Post

    Standard AW: Raspberry Pi 4 Ersteinrichtung für Anfänger mit Monitor und grafischer Desktopoberfläche statt S

    hallo DMW007 ich bin neuling in sachen raspberry und weiß nicht weiter. also, Raspberry Pi 4 Model B 8GB , 32GB micro sd mit Raspberry Pi OS with desktop and recommended software , angeschlossen an einer fritzbox zugriff vom pc win 10.
    mein problem : ich starte Putty gebe die ip vom raspberry ein alles klar mit konsole. nun starte ich den remotedesktop, gebe name und passwort ein und ... nix. der bildschirm bleibt hellblau und der dunkelblaue balken oben in der mitte zum minimieren u.s.w. leuchtet. nach ca.1 min. bekomme ich die meldung das mit sesman alles ok ist, login successful for dispay 10 started connecting connection problem, giving up some problem.
    ich hab doch aber mit bild auf der karte ???
    kannst du helfen ? danke schon mal

  4. #3
    Avatar von raspberryfan
    Registriert seit
    02.06.2014
    Beiträge
    36
    Thanked 7 Times in 7 Posts

    Standard AW: Raspberry Pi 4 Ersteinrichtung für Anfänger mit Monitor und grafischer Desktopoberfläche statt S

    Hey, cool hier andere Pi-Fans zu sehen Der Fehler sagt mir leider nichts. Kannst du vielleicht Screenshots posten damit man die exakte Fehlermeldung sieht und es besser versteht?
    Ich denke das würde helfen.

  5. The Following User Says Thank You to raspberryfan For This Useful Post:

    DMW007 (19.11.2021)

  6. #4
    Avatar von DMW007
    Registriert seit
    15.11.2011
    Beiträge
    4.741
    Thanked 8.849 Times in 2.786 Posts
    Blog Entries
    5

    Standard AW: Raspberry Pi 4 Ersteinrichtung für Anfänger mit Monitor und grafischer Desktopoberfläche statt S

    Hast du mal geschaut, ob der Standard-VNC Server vielleicht noch installiert ist? Der sollte am besten deaktiviert/deinstalliert werden, wenn XRDP genutzt wird. Kann sonst zu Konflikten mit der Sitzung kommen, wie z.B. diese Antwort nahe legt.
    Ansonsten ist es prinzipiell eine gute Idee, die Logs der Anwendung (also hier XRDP) mal durch zu schauen. Eventuell findest du dort einen Hinweis, warum genau er die Verbindung verliert.


  7. #5

    Registriert seit
    19.11.2021
    Beiträge
    3
    Thanked 1 Time in 1 Post

    Standard AW: Raspberry Pi 4 Ersteinrichtung für Anfänger mit Monitor und grafischer Desktopoberfläche statt S

    hallo raspberryfan , ich bin bisher noch nicht soviel in Foren unterwegs gewesen - besser gesagt, so gut wie nie - deshalb weiß ich nicht wo ich die Screenshots hochladen muß. sonst hätte ich das schon getan. heeee ich habs gefunden ... lade hoch.Name:  k 1.JPG
Hits: 86
Größe:  57,0 KBName:  k 2.JPG
Hits: 85
Größe:  58,7 KBName:  f 1.JPG
Hits: 85
Größe:  38,2 KBName:  f 2.JPG
Hits: 86
Größe:  37,8 KB

    ich hoffe du kommst mit meinem Dilettantismus klar
    Geändert von alf (19.11.2021 um 21:27 Uhr)

  8. The Following User Says Thank You to alf For This Useful Post:

    DMW007 (20.11.2021)

  9. #6
    Avatar von DMW007
    Registriert seit
    15.11.2011
    Beiträge
    4.741
    Thanked 8.849 Times in 2.786 Posts
    Blog Entries
    5

    Standard AW: Raspberry Pi 4 Ersteinrichtung für Anfänger mit Monitor und grafischer Desktopoberfläche statt S

    Die erste Meldung von Putty ist normal, wenn du den Pi neu installiert hast. SSH merkt sich aus Sicherheitsgründen einen Fingerabdruck, der zum SSH-Schlüssel gehört. Wenn sich der ohne zutun ändert, handelt es sich wahrscheinlich um einen Manipulationsversuch. Da du anscheinend eine zweite SD-Karte mit TwisterOS hast, unterscheidet sich der dortige Fingerabdruck vom bekannten und du erhältst diese Warnmeldung. In diesem Falle ist das erklärbar und somit unkritisch.

    Hast du nach dem VNC-Thema geschaut? Der scheint keine Sitzung öffnen zu können. Das spricht dafür, dass diese von was anderem Blockiert wird, wie in der Superusers-Frage gepostet. Ich habe noch kein vorgefertigtes Image mit dem kompletten Desktop zusammen mit RDP verwendet, sondern immer nur die Minimalinstallation und dann die minimale Desktopumgebung dazu. Wenn ich heute Zeit finde, teste ich das mal. Meine Vermutung ist, dass der im kompletten Desktop wohl auch VNC oder was anderes, dass die Sitzung verwendet, vorinstalliert. Würde mal schauen, was in der Config eingestellt ist und ob VNC-Pakete installiert sind:
    Code:
    sudo raspi-config
    sudo dpkg -l | grep vnc
    Aber wie gesagt, so lange du nicht in die Logs schaust was genau XRDP nicht passt, ist das nur raten.


  10. #7

    Registriert seit
    19.11.2021
    Beiträge
    3
    Thanked 1 Time in 1 Post

    Standard AW: Raspberry Pi 4 Ersteinrichtung für Anfänger mit Monitor und grafischer Desktopoberfläche statt S

    ich danke dir erstmal und werd schauen wie weit ich komme. ich werd mich auf jeden fall wieder melden und mitteilen wies gelaufen ist. ansonsten muss ich den 24/7 valheim-server auf twister packen .... das ist das nächste, von dem ich null ahnung habe. aber wie wir bei uns sagen - wer nichts riskiert kommt nie nach waldheim ( das ist ein knast bei uns )

    teil 2

    so, ich wieder. habe schöne fotos von meinem verbrechen am OS gemacht

    im sudo raspi-config sind 9 kategorien ... wo genau soll ich was machen ? wie gesagt, das sind meine ersten gehversuche mit raspi und mit linux. bin halt ein windowskind.

    Klicke auf die Grafik für eine größere Ansicht 

Name:	Unbenannt 1.JPG 
Hits:	17 
Größe:	160,8 KB 
ID:	9417Name:  Unbenannt 2.JPG
Hits: 81
Größe:  56,1 KBKlicke auf die Grafik für eine größere Ansicht 

Name:	Unbenannt 3.JPG 
Hits:	16 
Größe:	164,8 KB 
ID:	9419Name:  Unbenannt 4.JPG
Hits: 82
Größe:  28,3 KB
    Geändert von alf (20.11.2021 um 23:36 Uhr)

  11. #8
    Avatar von DMW007
    Registriert seit
    15.11.2011
    Beiträge
    4.741
    Thanked 8.849 Times in 2.786 Posts
    Blog Entries
    5

    Standard AW: Raspberry Pi 4 Ersteinrichtung für Anfänger mit Monitor und grafischer Desktopoberfläche statt S

    Ich habe es mit Raspberry Pi OS 11 (entsprechend deinen Screenshots bist du auch schon auf 11) auf einer frischen Installation versucht nachzustellen, d.H. per Imager das vollständige Desktop-Image installiert:



    Dann Paketquellen sowie Pakete aktualisieren und anschließend XRDP installieren, wie in meinem Beitrag beschrieben. Damit konnte ich das Problem nicht nachstellen. Allerdings ist mir aufgefallen, dass du laut deinem ersten Screenshot zusätzlich tightvncserver installiert hast. Meine Vanilla-Installation hat nur RealVNC als Server/Viewer, der für die VNC-Funktion in raspi-config genutzt wird:
    Code:
    $ dpkg -l | grep vnc
    ii  libvncclient1:armhf                   0.9.13+dfsg-2                      armhf        API to write one's own VNC server - client library
    ii  realvnc-vnc-server                    6.7.4.43891                       armhf        VNC® Server
    ii  realvnc-vnc-viewer                    6.20.529.42646                    armhf        VNC® Viewer
    Der kann natürlich auch die Sitzung blockieren, vor allem nachdem der extra installiert worden zu sein scheint. Ich würde den daher mal deinstallieren und neu starten:
    Code:
    sudo apt remove tightvncserver
    sudo reboot
    Wenn das nicht hilft, kannst du zusätzlich den integrierten VNC-Server deaktivieren bzw sicherstellen, dass dieser deaktiviert ist: sudo raspi-config, dann 3 Interface Options > P3 VNC und auf die Frage ob der VNC-Server aktiviert sein soll mit No antworten. Danach mit der <Tab> Taste zu Finish navigieren und den gesamten Pi neu starten. Generell ist der Weg über die Dienste okay (wobei da am besten systemctl genutzt wird), wenn du ein normales Debian hast. Da das Raspberry Pi OS ein angepasstes Debian ist, macht es prinzipiell Sinn, dort bevorzugt raspi-config zu nutzen.


  12. The Following User Says Thank You to DMW007 For This Useful Post:

    Darkfield (21.11.2021)

  13. #9
    Avatar von DMW007
    Registriert seit
    15.11.2011
    Beiträge
    4.741
    Thanked 8.849 Times in 2.786 Posts
    Blog Entries
    5

    Standard AW: Per Remotedesktopverbindung (RDP) auf den grafischen Desktop des Raspberry Pi zugreifen

    Hinweis: Dieses Problem ist neu seit Raspberry Pi OS 11, welches kürzlich erschienen ist. Der ursprüngliche Beitrag wurde mit Raspberry Pi 10 Buster erstellt, dort tritt der Fehler nicht auf. Wenngleich dort dieser Teil ebenfalls erklärt wurde. Allerdings zum damaligen Zeitpunkt mit dem Hinweis, dass dieser Schritt nicht erforderlich ist, wenn man die Desktop-Version installiert hat. Im Portal-Artikel wurde dies aktualisiert. YouTube erlaubt leider weder eine Aktualisierung des Videos, noch ein Einblenden von Hinweisen (dies war früher möglich, wurde aber entfernt). Daher kann ich es dort nicht direkt im Video ergänzen, sondern nur in den Kommentaren und in der Beschreibung.

    Mittlerweile konnte ich das Problem mit dem normalen Desktop (also nicht Full) nachstellen. Ausgangssituation: Frisch installierter Pi 4 mit Raspberry Pi OS 11. Anschließend die Paketquellen und alle Pakete aktualisieren. Das waren bei mir 70 Pakete und hat etwas gedauert. Nach der Aktualisierung wurde XRDP wie in meinem Beitrag beschrieben installiert.

    Im Log habe ich einen Fehler gefunden, dass die Schlüssel nicht gelesen werden konnten:
    Code:
    [ERROR] Cannot read private key file /etc/xrdp/key.pem: Permission denied
    Die Schlüssel gehörten Benutzer & Gruppe root. Das habe ich korrigiert:
    Code:
    sudo chown pi:pi /etc/xrdp/{key.pem,cert.pem}
    Dennoch erschien mehrere Minuten nur der XRDP Hintergrund, danach der gleiche Fehler wie bei @alf. In den Logs auf dem RPI war zu dieser Sitzung folgendes zu finden:
    Code:
    [20211122-22:50:39] [INFO ] connecting to sesman ip 127.0.0.1 port 3350
    [20211122-22:50:39] [INFO ] xrdp_wm_log_msg: sesman connect ok
    [20211122-22:50:39] [INFO ] sesman connect ok
    [20211122-22:50:39] [INFO ] sending login info to session manager, please wait...
    [20211122-22:50:39] [INFO ] xrdp_wm_log_msg: login successful for display 12
    [20211122-22:50:39] [INFO ] login successful for display 12
    [20211122-22:50:39] [INFO ] loaded module 'libxup.so' ok, interface size 9456, version 4
    [20211122-22:50:39] [INFO ] started connecting
    [20211122-22:50:39] [INFO ] lib_mod_connect: connecting via UNIX socket
    [20211122-22:54:09] [INFO ] connection problem, giving up
    [20211122-22:54:09] [INFO ] some problem
    Das Problem ist, dass - ähnlich wie Anfangs vermutet - der Pi durch die automatische Anmeldung am Desktop (Standardeinstellung) die Sitzung für XRDP blockiert. Um das zu lösen, gibt es zwei Möglichkeiten:
    1. Das automatische Anmelden in der Konfiguration deaktivieren.
    2. Einen eigenen Benutzer mit useradd erstellen, der nur für XRDP genutzt wird. Mit diesem meldet man sich also bei der RDP-Authentifizierung an.

    Am einfachsten und sinnvollsten ist vermutlich Variante #1, sofern ihr nicht die gleiche Sitzung lokal am Gerät und per RDP parallel nutzen möchtet (in diesem Falle ist RDP aber ohnehin das falsche Werkzeug). Händisch könnt ihr euch natürlich weiterhin am Pi mit dem gleichen Nutzer anmelden, nur RDP funktioniert dann eben so lange nicht, bis ihr euch abmeldet. Um das einzurichten, öffnet ihr das Konfigurations-Tool:
    Code:
    sudo raspi-config
    Dort zu 1 System Options, dann S5 Boot / Auto Login und B3 Desktop auswählen. Dadurch startet der Pi in die grafische Desktopumgebung, aber ohne sich automatisch anzumelden - das blockiert unter Bullseye die RDP-Sitzung.



    Anschließend mit der Tab-Taste nach unten zu <Ok> navigieren, dann erneut mit der Tab-Taste zu <Finish>. Die Meldung nach dem Neustart mit <Yes> bestätigen. Den braucht ihr, damit das sauber greift.



    Nach dem Neustart funktioniert RDP:



  14. The Following User Says Thank You to DMW007 For This Useful Post:

    Manipulate (27.11.2021)

  15. #10

    Registriert seit
    26.11.2021
    Beiträge
    1
    Thanked 0 Times in 0 Posts

    Standard AW: Per Remotedesktopverbindung (RDP) auf den grafischen Desktop des Raspberry Pi zugreifen

    Hallo,
    ich habe das gleiche Problem und habe es genauso gemacht wie hier beschrieben.
    Remotedesktop Bild bleibt trotzdem leer.

    Was kann ich machen?


    Edit1: es klappt nun alles, hab das Full Image genommen.
    Danke
    Geändert von Phaxy87 (26.11.2021 um 17:03 Uhr)

  16. The Following User Says Thank You to Phaxy87 For This Useful Post:

    DMW007 (27.11.2021)

Diese Seite nutzt Cookies, um das Nutzererlebnis zu verbessern. Klicken Sie hier, um das Cookie-Tracking zu deaktivieren.